Google Chrome Browser not supported for use with Courses or Exams

Google Chrome Browser not supported for use with Courses or Exams

Due to recent updates to the Google Chrome browser, Java content is no longer accessible via Chrome. As Java is a component of our course environment and is used throughout our services, Use of Google Chrome has been shown to cause key course components of our courses and examinations to malfunction. Therefore, online courses need to be accessed using a supported browser.

The following web browsers are still supported for use with our courses and exams:
Apple Safari
Microsoft Internet Explorer
Mozilla Firefox

For more information on our Supported Browsers, please see the following link:
http://help.excelsior.edu/recommended-software-and-computer-protection/

For more information on Google Chrome’s  Java compatibility, please see the following links:
Java’s announcement:
https://java.com/en/download/faq/chrome.xml

Google Chrome’s Announcement via the Chromium Blog
http://blog.chromium.org/2014/11/the-final-countdown-for-npapi.html

If you need assistance installing a supported browser please contact Technical Support. Contact information is available here